Another PostgreSQL challenge

Tried to install Documentum/PostgreSQL and got following error:

[SQL]   1006     CREATE  VIEW dm_acl_rp(r_object_id,i_position,i_partition,r_accessor_name,r_accessor_permit,r_accessor_xpermit,r_is_group,r_permit_type,r_applicati
on_permit)  AS  SELECT VE_.r_object_id,VE_.i_position,VE_.i_partition,VE_.r_accessor_name,VE_.r_accessor_permit,VE_.r_accessor_xpermit,VE_.r_is_group,VE_.r_permit_type,VE_.r_application_permit FROM dm_acl_r VE_  0.0008960000
[SQL]   1006    EXEC    0.0009740000
[SQL]   1006    Commit
[SQL]   1006    Commit
[SQL]   1006     INSERT  INTO dm_type_s VALUES('0302994880000100','dm_acl',' ',        21,         0,'dctm','1f02994880000101','1f02994880000102','2e02994880000101'
,1,         0,         0,        22,' ',-2147483392, timestamp '2017-03-11 12:46:45.000' , timestamp '2017-03-11 12:46:45.000' ,         0) 0.0010860000
[SQL]   1006     -- Object already exists --  STATE=23505, CODE=1, MSG=ERROR: duplicate key value violates unique constraint "d_1f02994880000008";
Error while executing the query

[DM_TYPE_MGR_E_CANT_SAVE_TYPE]error:  "Failure to insert row for type dm_acl in table dm_type_s: error from database system is  -- Object already exists --  STATE=23505, CODE=1, MSG=ERROR: duplicate key value violates unique constraint "d_1f02994880000008";

The root cause was that new ODBC driver (psqlODBC 09.06.0100) seems to be incompatible with Documentum, switching to previous version (psqlODBC 09.05.0400) resolves the problem.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s